Technology Support for Mac

Mac Users

  • For Velocicast to load you must have your browser updated to the latest version.  It must be at least 11.01.1 for the auction to load correctly.
  • Another option is to download Google Chrome browser.  Chrome does automatic updates for Flash and can be easier to maintain.  
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk